Cyfrowa stacja lutownicza

DSC00032Lutownica to podstawowe narzędzie elektronika, warto zadbać aby posiadać możliwość regulacji temperatury oraz aby sama kolba zasilana była 24V zamiast 230V. Chodzi tutaj o bezpieczeństwo swoje jak i montowanych układów oraz wygoda pracy. Stacja lutownicza jaką tutaj prezentuje posiada kilka zalet które wyróżniają ją spośród wielu dostępnych na rynku. Przede wszystkim chodzi tutaj o sterowanie mikrokontrolerem oraz wykrywanie zera fazy. Również istotnym argumentem jest tutaj cena, dla takich parametrów i funkcji jakie możemy uzyskać przy samodzielnie wykonanej stacji lutowniczej cena byłaby dość wysoka i często poza zasięgiem przeciętnego elektronika – hobbysty, te wszystkie argumenty skłoniły mnie aby wykonać ją samodzielnie. Ważne jest również to, że program napisałem do niej sam i każdy może w pełni dostosować go do własnych potrzeb.

Oprogramowanie:

DSC00031Program do tej stacji lutowniczej napisałem w BASCOMIE, wykorzystałem rączkę taką, jaka jest przy stacji SL 10/20/30. Ważne żeby termopara była typu K, można zastosować jakąkolwiek rączkę o takim właśnie typie termopary. W celu zmierzenia napięcia mikrokontroler korzysta z wbudowanego 10 – bitowego przetwornika A/C. Napięcie podane na przetwornik A/C jest wstępnie wzmocnione x 100 przez wzmacniacz operacyjny, dzięki temu uzyskujemy maksymalną rozdzielczość przetwornika – przy 22mV na wyjściu termopary mamy 2.2V na wyjściu wzmacniacza operacyjnego. Jako przelicznik temperatury z wyjścia termopary zastosowałem mnożnik napięcia zmierzonego przez przetwornik A/C, co prawda to nie jest najdokładniejsze określenie temperatury grota lutownicy, ale dla moich potrzeb w zupełności wystarcza. W wolnym czasie pewnie dopracuje to oprogramowanie wprowadzając kompensację temperatury zimnego końca termopary oraz sygnał PWM, choć i bez tego dokładność jest w zupełności wystarczająca, to jest lutownica – tu nie chodzi o 5 stopni w tą czy drugą stronę. Oczywiście udostępniam kod źródłowy który każdy może sobie przystosować dla siebie czy chociaż poprawić. Schemat elektroniczny zaczerpnięty został z artykułu w EP, jednak i tak wprowadziłem w nim pewne zmiany. Ostateczną wersję schematu przerysował Jarofon, za co mu dziękuję. Wykonałem również drugą wersję płytki PCB – jest mniej zworek i wszystko wygląda przejrzyściej.

DSC00022Stacja posiada również detektor wykrywający przejście fazy przez zero, dzięki temu gdy temperatura grota spadnie poniżej nastawionej to triak załączający zasilanie grzałki zostanie wysterowany dokładnie w momencie kiedy faza zasilania przechodzi przez zero, dzięki temu nie ma gwałtownych wzrostów prądów które powodują zakłócenia.

 

Przy pierwszym uruchomieniu stacji lutowniczej należy jednocześnie wcisnąć przycisk GÓRA i przycisk DÓŁ, dzięki temu ustawimy pierwszą wartość nastawy – 250 stopni, od tego momentu możemy z nią swobodnie pracować. Do ustawiania temperatury mamy dwa przyciski GÓRA i DÓŁ oraz przycisk UŚPIENIE który służy do przejścia w stan wstrzymania, po naciśnięciu tego przycisku nastawa zmienia się na 130 stopni. Po kolejnym naciśnięciu powraca normalny tryb pracy i również nastawa powraca do poprzedniej. Stację możemy w każdym momencie wyłączyć, po włączeniu ustawiona jest nastawa taka jaka była bezpośrednio przez jej wyłączeniem. Na wyświetlaczu wyświetla nam się przez cały czas bieżąca temperatura grota oraz temperatura jaka jest nastawiona. W trybie uśpienia wyświetla się jedynie temperatura bieżąca oraz napis UŚPIENIE. Gdy grzałka pracuje na panelu przednim świeci się dioda czerwona LED.

Zobacz kod źródłowy programu

Pobierz skompilowany program


Wykonanie:

DSC00035Płytka została wykonana metodą termotransferu,  zastosowałem wyświetlacz 2×16 znaków który wystarczy w nadmiarze do wyświetlania podstawowych parametrów (temp. grota i temp. nastawy). Umieściłem również wentylator chłodzący 12V, który podłączyłem na 5V dzięki czemu pracuje wolniej i ciszej, taka prędkość w zupełności wystarczy aby lekko ochłodzić radiatory znajdujące się na płytce. Nie ma elementów które by się mocno grzały, triak załączający pracę grzałki nawet podczas pracy jest jedynie lekko nagrzany. Panel zaprojektowany w Corelu, wydrukowany i przykryty warstwą plexi. Całość mieści się w obudowie po zasilaczu komputerowym. Płytka drukowana jest przytwierdzona do dolnej części obudowy małymi kątownikami i jest w pozycji pionowej, dzięki czemu nie zajmuje ona dużo miejsca i całość wygląda estetycznie.

Temat Cyfrowej stacji lutowniczej na forum elektroda.pl


Rozkład wyprowadzeń wtyku przy rączce do stacji lutowniczych SL 10/20/30:

wtyk

 

Schemat ideowy (część zasilacza):

ideowy11

 

Schemat ideowy:

ideowy22

 

Schemat montażowy:

montazowy

Pobierz schemat płytki drukowanej gotowy do drukowania

 

Schemat montażowy (nowa wersja):

montazowy2

Pobierz schemat płytki drukowanej gotowy do drukowania (nowa wersja)


Galeria:

 


102 Responses to Cyfrowa stacja lutownicza

  1. Jancenty napisał(a):

    Mam pytanie odnośnie stacji
    Podpiąłem wszystko jak na schemacie, jednak po podłączeniu na wyświetlaczu wyskakuje informacja:
    TEMP: 25,0 st C
    NASTAWA: -0,0 st C

    Naciskałem przyciski góra i dół razem, niestety stacja nie reaguje 🙁 nie wiem co jest grane ;( pomoże ktoś??

    Dodatkowo mam pytanie odnośnie masy we wtyku trzeba go gdzieś podpiąć czy ma on być wolny?? Na zdjęciach nie widać 5 kabelka stąd moje pytanie 🙂

    Pozdrawiam i dziękuję za szybką pomoc

    • Kamil Szkutnik napisał(a):

      Witaj serdecznie,

      Sprawdź dobrze czy masz odpowiednio podłączone przyciski. Stacja powinna zmienić nastawę na 250 stopni przy jednoczesnym wciśnięciu przycisków „góra” i „dół”. Masę z wtyku podepnij pod obudowę stacji lutowniczej.

      Pozdrawiam!

      • Jancenty napisał(a):

        Przyciski podpinam pod złącze JP1, 1 i 2 dla jednego przycisku a 3 i 4 dla drugiego, czy bez podpiętej masy mogą pojawiać się takie problemy?? Dopiero jutro podepnę masę i sprawdzę.

        Jeśli nie to jest problemem to masz może jeszcze jakieś pomysły??

        Pozdrawiam i dziękuję za zainteresowanie 🙂

      • Jancenty napisał(a):

        Przyciski rozkminiłem 🙂 ale problem następny jak podepnę kolbę to grzeje się strasznie BT-138 i wyświetlacz się rozjaśnia 🙁 co może być przyczyną?? Masz może jakiś pomysł??

  2. Przemek napisał(a):

    Witam 🙂
    Posiadam kolbę ze stacji lutowniczej ZD-912 z termoparą typu E, potrzebuję wprowadzić zmiany do programu jednak za bardzo nie wiem jakie wartości powinienem przyjąć. Doczytałem się tylko tyle, że termopara typu E ma czułość 68µV/°C. Będę wdzięczny za pomoc. Pozdrawiam Przemek

    • Kamil Szkutnik napisał(a):

      Witaj Przemku,
      wystarczy że zmienisz w kodzie wartość „0.0049” na odpowiednio mniejszą. Ja zrobiłbym to metodą prób i błędów. Możesz zmierzyć temperaturę grota przy np. 300 stopniach i odpowiednio skorygować wskazanie temperatury poprzez zmianę wspomnianego parametru.

      Pozdrawiam.

  3. bartek p napisał(a):

    Witam
    Na schemacie sa pokazane zworki,jednak nie ma zaznacoznych tych które robiłeś przewodem,np 5V na atmege ze stabilizatora.
    Mozna prosić o kompletny schemat montażowy ze wspomnianymi połaczeniami ?

    • Kamil Szkutnik napisał(a):

      Witaj,

      na schemacie nie zaznaczałem zworek które robiłem przewodem aby nie zaciemniać widoku, łączone pola są oznaczone etykietami – np. VCC.
      Generalnie, polecam korzystanie z nowej wersji schematu gdzie takich łączeń nie trzeba stosować.

      Pozdrawiam,
      Kamil Szkutnik

      • bartek p napisał(a):

        Byłem zmuszony zrobić pierwszą wersje ponieważ tylko w niej był schemat w eaglu a płytka była wykonywana na CNC.
        Mógłbym prosić o schemat z połączeniami przewodem?
        Pozdrawiam

  4. glasers napisał(a):

    Witam

    Czy było by możliwe wykonanie takiej stacji na sprzedaż ? chętnie bym kupił złożoną

    • Kamil Szkutnik napisał(a):

      Witaj,
      obecnie nie jestem w stanie wykonać takiej stacji na sprzedaż.

      Pozdrawiam,
      Kamil Szkutnik

  5. bartek p napisał(a):

    Witam
    Wykaz elementów w wersji v2 jest zmieniony czy został taki sam?

  6. quartis napisał(a):

    Witam. Fajna konstrukcja. Mam rączkę do SL 30 i nie bardzo działa ze starą stacją. Czy można dodać pdf z samymi narysowanymi elementami bez ścieżek?

  7. Marcin napisał(a):

    Hey.
    Przymierzam się do budowy stacji i mam takie pytania:
    1.Czy najlepiej będzie użyć trafo 2x12V
    2.Czy wentylator nie jest zbędny?

    Ma może ktoś listę wykaz elementów pod płytkę v.2 🙂

    • Kamil Szkutnik napisał(a):

      Witaj,
      najlepiej będzie użyć właśnie transformator 2x12V. Być może wentylator nie jest konieczny, tyrystor w ogóle się nie grzeje podczas pracy 🙂

  8. Piotr B. napisał(a):

    Jak kolega Kamil wyżej napisał, powoli już przygotowuję publikację mojej wersji stacji.
    Natomiast sugestia dla kolegi kamila. Może warto ustawić wyświetlanie komentarzy on najnowszego od góry ? Nie trzeba by przelatywać całej strony komentów by zobaczyć najnowszy.

    • Kamil Szkutnik napisał(a):

      Słuszna uwaga Piotrze, zmieniłem układ komentarzy. Teraz rzeczywiście jest wygodniej.
      Dziękuję za pomocną opinie.

    • Rafik napisał(a):

      Kiedy można spodziewać się nowej odsłony, mam zamiar stworzyć taką stację w oparciu o ten projekt. Jak będzie nowsza to jeszcze lepiej 🙂

  9. Piotr B. napisał(a):

    Na dniach powinna ukazać się moja całkowicie nowa odsłona stacji lutowniczej autorstwa kolegi Kamila.
    Zmiany w stosunku do wersji autora są następujące:
    – dodałem trzy przyciski szybkiego zapamiętania temperatury
    – włączanie i wyłączanie stacji posiada tzw miękikie sterowanie
    – pobór energii w stanie wyłączenia 0mA
    – automatyczne przejście w stan uśpienia po 15 minutach nieużywania stacji
    – automatyczne wyłączenie stacji po upływie 30 minut od ostatniej aktywności stacji
    Zmiany te pociągnęły za sobą również zmianę obwodu drukowanego.

    • Jancenty napisał(a):

      do: Piotr B.

      czy nowsza wersja stacji lutowniczej powstała?? jeśli tak to można dostać namiary ??

      • Kamil Szkutnik napisał(a):

        Kontaktowałem się jakiś czas temu z Piotrem. Dostałem informację że obecnie jest mocno zajęty, ale gdy znajdzie tylko czas na pewno umieści materiały odnośnie jego ulepszeń i zamieści również tutaj te informacje.

        Pozdrawiam

  10. set666 napisał(a):

    Witam
    jestem początkujący w temacie.
    zakupiłem na allegro programator usbasp z przystawka z podstawkami pod procki, atmege 8.
    płytkę wytrawiłem wlutowałem na razie rezystory i podstawkę pod procka.
    Chciałbym wrzucić twój wsad do procka ale nie mam pojęcia jak to zrobić 🙁
    Czy możesz w jakiś prosty sposób wytłumaczyć albo dać jakieś linki jak to zrobić?

  11. Greluax napisał(a):

    Witam, pewności nie mam, ale zapytam.

    pod złącza zasilacza X1-1 X1-2 X1-3 X1-4 podłączam trafo 2x12V to jest jasne . Pod złącze X2-1 i X2-2 podaje 24 V ale czy z tego samego trafa czyli z pkt. X1-1 i X1-4 ?

    Z góry dzieki za pomoc.

  12. Piotr Bechcicki napisał(a):

    W linku poniżej najnowszy kodzik do stacji kolegi Kamila. Troszkę poprawek i ulepszeń.

    http://gg.pl/dysk/6un5sLiTIJst6-n5sLiTOVg/stacja%20lutownicza.bas

  13. Piotr Bechcicki napisał(a):

    Proszę o napisanie na mojego maila to jest matrix0606@op.pl a chętnym podeślę wszelkie kody.

  14. Łukasz Bykowski napisał(a):

    Witam. Gratuluję autorowi i jednocześnie mam prośbę do Pana Piotra Bechcickiego. Czy mógł by Pan podesłać zmieniony wsad ( z poprawkami, które Pan zaproponował ) wydają mi się bardzo stosowne i przydatne. Jeśli jest taka możliwość to prosił bym o wersje nie skompilowaną wsadu jak i o plik HEX. Z góry dziękuję i pozdrawiam Autora jak i osoby które czynnie włączyły się w projekt.

  15. Piotr Bechcicki napisał(a):

    Chodzi Ci o dławik 10uH? Jeśli nie masz to możesz zastąpić go zworą.

  16. emil napisał(a):

    witam mam pytanie jeżeli nie mam dławika takiego co moge zrobić ??

  17. Dmaian napisał(a):

    Jak podłączyć rączkę lutownicy ?

  18. Piotr B. napisał(a):

    Jak grzeje Ci się stabilizator to sprawdź czy nie masz gdzieś zwarcia. Może w niewlaściwe miejsce go wlutowałeś?

  19. masterek napisał(a):

    Witam!
    Zmontowałem płytke tej lutownicy w wersji 2 i jak włacze zasilanie to 7809 grzeje sie okropnie. na wyswiatlaczu nic sie nie pojawai i wg…. Moze mi ktoś wytłumaczyc co moze jest ni tak?? a moze jest jakis bład na płytce lub w schemacie?

  20. Kamil napisał(a):

    Witam mam na sprzedaż dwie płytki gotowe do wytrawienia z naniesionym układem. Cena wywoławcza za jedną to 20 zł z przesyłką ;D. Jak by ktoś byl zainteresowany to proszę pisać na pocztę: kamilwidmo@gmail.com

  21. Piotr Bchcicki napisał(a):

    Przepraszam za to wpychanie się z butami, ale jeszcze mala propozycja odnośnie tego komunikatu o podłączeniu rączki lutownicy. Po zmianie jaką w poniższych postach zaproponowałem, proponuję też poprawić zabezpieczenie przy odłączeniu rączki napisać tak:

    Do
    Home

    Wart_ac = Getadc(0)
    Waitms 100
    V = Wart_ac * 0.0049
    Temp = V * 260
    Temp = Temp + 25
    Temp_lcd = Fusing(temp , „#.&”)

    If Temp > 800 Then
    Home
    Lcd ” Podlacz raczke”
    Lowerline
    Lcd ” lutownicy ”

    Ustawienie ręczne temperatury nie podwyższy nam jej powyżej 550st. C a jak odłączymy rączkę to procesor wykryje na wejściu ADC liczbę powyżej 800 a dokładnie mówiąc równo 1023 więc komunikat o prośbę podłączenia rączki i tak wyskoczy.

    Jeszcze raz przepraszam autora za te zmiany w jego kodzie, ale myślę że wszystkim wyjdą na dobre.

  22. Piotr Bchcicki napisał(a):

    Jeszcze mam dwie uwagi co do programu stacji. Nie wiem jaka jest optymalna temperatura dla stacji lutowniczej ale:
    1 – Nie zabezpieczyłeś się przed próbą ustawienia temperatury ujemnej jak też powyżej 600st,C
    2 – Proponuję usunąć BITWAIT w miejscach zwiększania i zmniejszania nastaw temperatury co pozwoli na zmiany poprzez zarówno przytrzymanie jak też naciśnięcie przycisków góra dół.

    Proponuję również podprogramy zwiększania i zmniejszania ustawień zmienić tak:

    Wiecej_pr:
    if nastawa 50 then
    Nastawa = Nastawa – 10
    Waitms 100
    Writeeeprom Nastawa , 2
    end if
    Return

    To nie pozwoli na ustawienie temperatury mniejszej niż 50 a to i tak pewnie dużo za mało i nie pozwoli na ustawienie temperatury wyższej niż 550stC.

    Przepraszam że się tak wpycham w nieswój soft, ale myślę że wielu tych którzy będą chcieli zrobić ową stację przyda się to.

  23. Piotr Bchcicki napisał(a):

    Drogi Kamilu, dziękuję za odpowiedzi na moje pytania. Po poprawieniu przez Ciebie schematu mam pytanie:
    czemu dałeś rezystory 990k i 10k? Teraz wzmocnienie wynosi 99. Zamiast 990k daj 1M i będzie równo 100. Wiem czepiam się, ale przecież nietrudno dać 1M i wtedy będzie ok.

  24. Kamil Szkutnik napisał(a):

    Piotr – Transformator powinien mieć 50VA. Jeżeli chodzi o wzmacniacz operacyjny sygnału z termopary – Twoje pytanie mnie zaskoczyło, jednak masz 100% racji – przy takim stosunku rezystorów wzmocnienie wynosiłoby 1. Błąd leży po stronie schematu, poprawiłem schemat tak, aby wzmocnienie sygnału termopary wynosiło 100. Dzięki za cenną uwagę 🙂

    Kuba – jeżeli stacja uruchomiła się a na wyświetlaczu pojawia się tekst to znak że układ jest prawidłowo zaprogramowany, jeżeli znajdziesz jakieś niedogodności w korzystaniu z napisanego przeze mnie interfejsu możesz zmodyfikować kod programu według własnych potrzeb.

    Pozdrawiam

  25. Piotr napisał(a):

    i jeszcze jedno pytanie:
    czemu w obwodzie wzmacniacza OP są akurat rezystory 990k? jeśli są to dwa takie same oporniczki to czy można dać inne? przecież wzmocnienie wyznacza stosunek R9 do R10, a skoro oba są jednakowe to wzmocnienie wynosi 1.

  26. Piotr napisał(a):

    ile VA powinien mieć transformator?

  27. Kuba napisał(a):

    Witam, czy to, że bez podłączonej rączki lutownicy temperaturę da się ustawić powyżej 500 stopni to wina błędów podczas programowania lub samego programatora, czy to coś innego.

  28. Harnas napisał(a):

    Ten z EP jest chyba pewniejsze bo sam miałem problem z uruchomieniem a chodziło tylko o wartość bodajże o R10 aby miał 1k a nie 1M,tak samo w wersji płytki 2 brakuje połączenia z masa AGND i podpiętych z nią paru elementów.

  29. Tomek napisał(a):

    W płytce w wersji nr2 jest mniej rezystorów i różnią sie wartością czy to jest ok? ponieważ zastanawiam sie która płytke robić

  30. Kuba napisał(a):

    Witam
    stacja uruchomiona na razie bez kolby ale kontroler chodzi, problemem był wyświetlacz, po podłączeniu nowego wszystko działa 🙂

  31. Kamil napisał(a):

    Dzieki. Wlascciciel chyba sie nie obrazi ;). A czy macie jakiś wykaz elementow do tego ? bo na EP troche sie rozni od tego tutaj.

  32. Kuba napisał(a):

    Raczej nie jest potrzebny aż tak mocny transformator, moim zdaniem wystarczy
    taki ok. 60W, a napięcia będą dobre 2x12v.
    Przepraszam właściciela strony, że odpowiadam za niego 🙂

  33. Kamil napisał(a):

    Dziekuje za odpowiedź i w zasadzie to mam jeszcze jedno pytanie. Czyli najlepiej jest kupić transformator toroidalny 100W 2x12V tak ?

  34. kuba napisał(a):

    Tak trzeba podpiąć zasilanie w oba miejsca, te ~24V to zasilanie właśnie grzałki a 12V-0-12V to zasilanie elektroniki,

  35. Bart napisał(a):

    Witam ponownie 8)

    Mam pytanie bo już całkowicie zgłupiałem… Czy w ver2 płytki zasilanie mam podłączyć do 24V i do 12V – GND – 12V ? Czy tylko do tego 2×12 ? Coś nie chce mi grzać a nie chce nic spalić… będe wdzięczny za szybką odpowiedź

    Pozdrawiam

  36. kuba napisał(a):

    No niestety to chyba nie zimne luty, przelutowałem wszystkie styki od nowa, a taśmy nie mam gdyż w płytkę jest wlutowana listwa goldpin a w wyświetlacz gniazdo na goldpiny

  37. Bart napisał(a):

    Ja miałem kwadraty na wyświetlaczu jak miałem „zimne luty na konektorach od LCD… sprawdź też czy taśma dobrze styka. Niektórzy mówią, że trzeba nacisnąć „góra” i „dół” jednocześnie, żeby stacja wystartowała

  38. Kuba napisał(a):

    Stabilizatory się nie grzeją jednak pojawił się nowy problem na wyświetlaczu migają tylko kwadraciki atmega8 zaprogramowana tym nowym wsadem

  39. Kuba napisał(a):

    Witam
    dziękuje za podpowiedź dopiero pod lupą zauważyłem ikro zwarcie punktu lutowniczego z cyną teraz 7809 nie grzeje się

  40. Kamil Szkutnik napisał(a):

    Tomek – Wersja 2 płytki drukowanej posiada mnie zworek, jest prostsza w montażu. Numerki elementów mogą się różnić z projektem w EP, jednak schemat montażowy v2 ma numery elementów analogicznie ponumerowane do schematu ideowego zamieszczonego na stronie

    Kamil – na płytce drukowanej nie ma przewidzianego miejsca dla wentylatora, możesz takie złącze dołączyć do płytki lub wlutować się gdzieś gdzie znajdziesz napięcie 5 do 12V, w zależności jaką prędkość chcesz uzyskać. Ja proponuje zasilić wiatrak o napięciu nominalnym 12V napięciem 5V, jest wtedy niesłyszalny dla człowieka a aktywne chłodzenia działa.

    Bart, Kuba – nie pamiętam czy LM7909 u mnie grzał się mocno, podepnij w szereg amperomierz bezpośrednio przez lub za LM7909 i zmierz prąd, jeżeli płynie 1.5A za układem to znaczy że gdzieś jest zwarcie.

  41. Kuba napisał(a):

    Witam no właśnie mi też okropnie grzeje się stabilizator 7809 ale tylko jeśli atmeg8 jest włożona, gdy wyjmę procka to stabilizator staje się chłodny, czy to uszkodzony procek, czy błąd w lutowaniu, dzięki

  42. bart napisał(a):

    Witam,

    czy to normalne, że 7909 dużo się grzeje ? I drugie pytanie czy da się jakoś ominąć wzmacniacz OP07 i podłączyć regulacje ze znacznie mniejszą dokładnością ?

  43. Kamil napisał(a):

    Witam. Panie Kamilu może mi Pan napisać gdzie należy się podpiąć z tym wiatrakiem ?

  44. Tomek napisał(a):

    Witam wszystkich mam pytanie, zamierzam zbudować owa stacje i mam pytanie odnośnie płytki drukowanej przedstawionej na stronie czym sie rózni wersja 1 od wersji poprawione v2? czy obie sa poprawne?. drugie pytanko patrząc na schemat ideowy niektóre części sa wartościami inne niz w projekcie z EP?

    z wyrazami szacunku

  45. Bartosz napisał(a):

    czy na tej nowej płytce nie ma czasem zwarcia lini MOSI z masa i Vcc?

  46. Bartosz napisał(a):

    Wtyczka to gniazdo DIN 5. Ja mam pytanaie czy nadaje sie do tej stacji transformator 2×12 V? jesli tak to jak go mam podłaczyc?

  47. Zbyszek napisał(a):

    Witam,

    Bardzo spodobał mi się ten projekt, powolutku zabieram się do jego wykonania (w chwili obecnej kompletuje części) i mam jedno pytanie, a mianowicie. Jak nazywa się ta wtyczka do lutownicy, bo mam problem ze znalezieniem jej w sklepie.

    pozdrawiam

    • Kamil Szkutnik napisał(a):

      Ja ją znalazłem dzięki mailowi do pracownika danego sklepu elektronicznego ze zdjęciem interesującej mnie wtyczki. Nie mam pojęcia jakie ta wtyczka ma oznaczenia choć na pewno jakieś ma, wiem że takie rozwiązanie było stosowane w systemach audio (przynajmniej w Polsce).

      Pozdrawiam

    • Kamil Szkutnik napisał(a):

      Witaj Bartosz,
      znajdujesz uzwojenia wtórne tych dwóch transformatorów (czyli tam gdzie masz ~12V) i łączysz je szeregowo. W ten sposób stworzyłeś wyprowadzenia: ~12V – GND – ~12V. Między krańcowymi wyprowadzeniami (~12V) masz 24V. I teraz te trzy utworzone wyprowadzenia podłączasz tak jak na schemacie montażowym PCB. Jeżeli chodzi o płytkę – ja nie widzę zwarcia między tymi liniami na PCB, wszytko jest ok.

      Pozdrawiam

  48. Harnas napisał(a):

    Przed chwila rozwiazalem problem
    zwarcie AREF do masy(malutka kropleka cyny)

  49. Harnas napisał(a):

    Co możne być przyczyna ze nie działa mi ta stacja?
    Wszystkie czesci sa sprawne,wykreśliłem parę linijek kodu i:
    na wyjściu Przetwornika ADC by ciągle wynik 1023 niezależnie napięcia na PC0
    Atmega8 był zupełnie nowy włożyłem drugą atmege i ten sam efekt;(

  50. Krzysiek napisał(a):

    ojoj, już znalazłem na necie projekt z ep, przepraszam za zamieszanie 🙂

  51. Krzysiek napisał(a):

    przydałaby się lista potrzebnych elementów, bo coś mi eagle szwankuje i nie chce otworzyć projektu…

  52. Radek napisał(a):

    Kamilu , dziękuję za pomoc , pozdrawiam.

  53. miszczo napisał(a):

    Witam
    Bardzo ciekawa konstrukcja. Zamierzam ją wykonać i mam kilka pytań
    Mianowicie
    Czy mogę zastosować transformator toroidalny 2x13v? Co w tym przypadku musiałbym zrobić?
    Następnie na schemacie montażowym stacji v2 nie możliwe do odczytu są wartości kondensatorów pomiędzy atmegą a lm311n chodzi o c19. Próbowałem odczytać ze pliku eagla ale jest tam nałożone kilka kondensatorów na siebie c12 na c13 i jeszcze c13.Czy tych kondensatorów nie powinno być? Nie mogę ich sie dopatrzeć na schemacie ideowym
    I jeszcze jak nazywa się złącze lutownicy? Czy znajdę je w sklepie avt?
    Pozdrawiam

  54. Radek napisał(a):

    Witam , w końcu udało mi się odpalić stację , podłączyłem rączkę od stacji PT 936.
    Po nastawieniu temperatury 460 C- 500 C wyświetla się komunikat podłącz rączkę , dla niższych nastaw
    wszystko działa bez problemu. Co może powodować takie działanie ? ( termopara wbudowana w rączkę PT ma niższy zakres temperaturowy ?)

    • Kamil Szkutnik napisał(a):

      Radek – przy 500 stopniach wyświetla się komunikat o niepodłączonej rączce ponieważ tak zaprogramowałem stację, jest to mój sposób na programową detekcję odłączonej rączki. Możesz tą funcję usunąć w programie, wtedy wszystko będzie w porządku. Ewentualnie jak będziesz miał z tym problem mogę Ci pomóc. Uważam że 500 stopni nastawy to mocno przesadzona temperatura, wystarczy 250 – 300 stopni.

  55. Kamil Szkutnik napisał(a):

    Bartek – przykro mi że zostałeś narażony na dodatkowe koszty, teoretycznie można zrobić sterowanie do kolby na 230V AC, jednak bez wbudowanej termopary nie masz mozliwości odczytu aktualnej temperatury grotu – więc to sie mija z celem, ale możesz używać tej kolby samej do lutowania. Ma odpowiednią moc a grot wydaje się być dobrej jakości.

    Koszarki – ja użyłem tutaj mostek KBL04 4A/400V, jednak można zastosować mostek o dużo słabszych parametrach.

  56. Bartek napisał(a):

    A ja mam jeszcze pytanie. Czy można tak przerobić układ aby zasilać lutownicę napięciem AC230V? Czy byłaby to duża ingerencja w układ?

  57. 2010 napisał(a):

    Witam! Jaki mostek prostowniczy zostal tu uzyty? (?-A,?-V)

  58. Bartek napisał(a):

    Rozumiem. Wcześniej pytałem sie czy mogę wykorzystać rączkę z lutownicy Salomon na którą dostałem pozytywną odpowiedź. Teraz widzę że potrzebuję inną rączkę, gdyż Salomon jest na 230V i ma 40W

  59. Kamil Szkutnik napisał(a):

    Radek – Sprawdź czy coś Ci nie obciążą układu,
    podaje opis złącza JP4:

    1 – OK
    2 – Dół
    3 – Góra
    4 – GND

    Bartek – rączka lutownicy musi byc na 24V i jej moc nominalna powinna wynosić 48W, taki opis powinien widnieć na na opakowaniu czy na samej rączce. Jest mało prawdopodobne aby rączka lutownicy na 24V nie miała termopary.

  60. Radek napisał(a):

    Układ zmontowany , ale dzieje się u mnie coś dziwnego. Na wyjściu z mostka prostowniczego mam 35 V .

  61. BARTEK napisał(a):

    Witam,
    Rozebrałem tą lutownicę i tam nie ma żadnych innych kabli oprócz prądowych i uziemienia. I co teraz?

  62. Radek napisał(a):

    To w takim razie spróbuję dzisiaj kupić taki rezystor. Kamilu gdzie powinienem podpiąć przyciski sterujące ?

  63. Radek napisał(a):

    Kamilu dzięki za szybkie odpowiedzi. Mam kolejne pytanko – rezystor R9 990 K ,
    chyba taki nie występuje w typoszeregu. Myślę , że można by połączyć 3 rezystory 330 k szeregowo i takiego potworka wlutować.

    • Kamil Szkutnik napisał(a):

      Istnieją takie, jeden nawet leży obok mnie. Jednak są to rezystory o zwiększonej dokładności, i taki jest zalecany. Możesz oczywiście połączyć takie jakie masz, też wszystko będzie działać.

  64. Radek napisał(a):

    Czy mogę zastosować transformator 2 x 12 V z 4 wyprowadzeniami ( połączyć koniec pierwszego uzwojenia z
    początkiem drugiego ) ?

  65. Radek napisał(a):

    Witam

    Czy pomiędzy x1-1 X1-4 powinno być 24 V , a pomiędzy X1-3 x1-4 , X1-1 X1-2 12 v ?

  66. P.F. napisał(a):

    Oczywiście prośba do ARTURA. Czy możesz podesłać twojego hexa kpf(małpa)autograf.pl
    Z góry dzięki.

  67. artur napisał(a):

    Znalazłem problem a mianowicie plik hex który jest do ściągnięcia jest do bani.
    skompilowałem załączony program i wgrałem do atmegi i wszystko śmiga.
    plik wynikowy ma 9kb a nie jak ten zamieszczony 2 kb

  68. gg napisał(a):

    układ zmontowany i sytuacja taka jak u kolegi poniżej, po zaprogramowaniu atmegi na wyświetlaczu tylko kwadraty, układ nie działa prawidłowo, czy autor znalazł może już rozwiązanie z tym wsadem do atmegi?

  69. PF napisał(a):

    Witam !!!

    Zrobiłem układzik wszystko ok poza tym że wcale nie stertuje. Na wyświetlaczu martwa cisza , przy maksymalnym kontraście świecą tylko kwadraty w górnej linii. Czy komuś to urządzenie wystartowało z tym wsadem. Zaprogramowanie Atmegi na fabrycznych fusach to nie jest trudna sprawa.

  70. Bartek napisał(a):

    Dzięki, postaram się z tym uporać. Dam znać niebawem.

  71. NIEBO! napisał(a):

    Czy mogę zapytać z którego EP pochodzi idea projektu? Będę budował na pewno tą konstrukcję!!! 🙂

  72. artur napisał(a):

    Właśnie buduje przedstawioną stacje i mam z nią problem a mianowicie po załączeniu zasilania na wyświetlaczu zaświeca się cały górny rząd i nic poza tym. dzieje się tak również po wyjęciu atmegi. wyświetlacz sprawny przetestowany atmega programowana na różnych programatorach jest ok. płytkę sprawdziłem dwukrotnie pod kątem zwarć i nic. brak mi pomysłów. dodam że stacja posiada oddzielne trafo dla grzałki 24v 80W i oddzielne dla elektroniki 2x12V 9W , trafa nie są połączone ze sobą. Macie morze jakieś pomysły?

  73. Łukasz2806 napisał(a):

    Próbował już ktoś ten skompilowany wsad.HEX? U mnie on nie dziala.

  74. Kamil Szkutnik napisał(a):

    Bartek – rączka od solomon sr 963 będzie odpowiednia, pod warunkiem że uporasz się z wyprowadzeniami, mogą być inne niż te przedstawione w artykule.

    Łukasz2806 – Fusebity mają być takie jak są domyślnie ustawione w mikrokontrolerze Atmega8. Jeżeli chodzi o problem z zaprogramowaniem to nie ma to związku z układem Stacji lutowniczej, problem najprawdopodobniej leży po stronie programatora albo mikrokontrolera.

  75. Łukasz2806 napisał(a):

    Zrobilem tą stacje… Jak ustawić Fusebity? Wsad ładuje Pony Progiem niestety nie dziala

  76. Bartek napisał(a):

    Witam,
    Bardzo ciekawy projekt. Właśnie buduję podobną stację lutowniczą,lecz nie mogę dostać rączki lutownicy w łodzi. Czy można by przerobić tą solomon sr 963 lutownicę na taką rączkę do stacji?

  77. Kamil Szkutnik napisał(a):

    Zsolt – conversation in progress

    Karol – oto mały kosztorys elementów:
    rączka lutownicy 35zł
    trafo 25zł
    wyświetlacz 15zł
    inne el. elektroniczne 10zł
    obudowa od zas. komp – każdy powinien gdzieś znaleźć 😉

    Oczywiście większość elementów miałem, pewnie Ty tez coś znajdziesz w domu. Ja musiałem tylko dokupić rączkę lutownicy, wyświetlacz LCD i uC.

  78. Zsolt napisał(a):

    Hi,
    „Cyfrowa stacja lutownicza hex file”

    Unfortunately the hex file I programme it vainly it AVR-in it LCD is out of order.
    The program does not start, only the original program of the connection, the you hex your file not.
    What may be the mistake?
    Is there some special setting in the course of the programming?
    I wait for your answer.

    Best regards

  79. Zsolt napisał(a):

    Program nie zapoczątkowuje tego AVR-the błąd może być górą, nas?
    Oparzenie programu tam jest jakiś rodzaj scenerii?
    Chciałbym prosić o pomoc!

  80. Kamil Szkutnik napisał(a):

    Jeżeli chodzi o kalibrację, to w tym projekcie praktycznie jej nie ma. Jedyny potencjometr służy do nastawienia kontrastu wyświetlacza. Ewentualnie jeżeli rączka lutownicy byłaby nietypowa można wprowadzić niewielką korektę w programie, chodzi mi tutaj o mnożnik napięcia termopary. Jednak w 95% przypadkach wszytko powinno być w porządku z odczytem temperatury.

    Pozdrawiam!

  81. Waldek napisał(a):

    Witam! Ładna i pomysłowa konstrukcja,a jak wygląda sprawa z kalibracją.Wszystko przebiegło bez problemów?

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *